Links Markups in a DWF file into the project document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- file
- Type: SystemString
Full path of the file to link. File must exist and must be a valid DWF file.
- options
- Type: Autodesk.Revit.DBDWFImportOptions
Various link options applicable to the DWF format.
Return Value
A collection of link instance element ids created by the markup link.Remarks
Link isn't supported for family documents. Please use import instead.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Not a valid file for DWF import (.dwf or.dwfx files are valid). -or- Some of the views are not importable. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsFileArgumentNotFoundException | The given file does not exist. |
Autodesk.Revit.ExceptionsInvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |