AddPoint Method


Inserts a IndexPoint into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddPoint(
	IndexPoint point
)
Visual Basic
Public Sub AddPoint ( _
	point As IndexPoint _
)
Visual C++
public:
void AddPoint(
	IndexPoint^ point
)

Parameters

point
Type: Autodesk.Revit.DB.DirectContext3DIndexPoint
The point to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also