Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- isSolid
- Type: SystemBoolean
Indicates if the Sweep is Solid or Void.
- path
- Type: Autodesk.Revit.DBReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
- profile
- Type: Autodesk.Revit.DBSweepProfile
The profile to create the new Sweep. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
- profileLocationCurveIndex
- Type: SystemInt32
The index of the path curves. The curve upon which the profile plane will be determined.
- profilePlaneLocation
- Type: Autodesk.Revit.DBProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.
Return Value
If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.Remarks
This method creates a sweep in a family document. The sweep will trace the profile along the path.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input argument-path-is a null reference (Nothing in Visual Basic) or empty or an unsupported curve type. |
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument-profile-is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the creation failed. |