A unique identifier used for a bar within a variable length rebar set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This property affects only Rebar sets under the following conditions:
- 1. The distribution type ([!:Autodesk::Revit::DB::Rebar::distributionType]) of the Rebar is DistributionType::Enum::VaryingLength.
- 2. There are at least two bars within the Rebar set that have different shape parameter values (i.e at least two bars vary in length).
The shape parameters of a Rebar can be accessed via [!:Autodesk::Revit::DB::Structure::RebarShapeDefinition::getParameters] method.
The parameters at a specific index in a Rebar set can be accessed via [!:Autodesk::Revit::DB::Structure::Rebar::getParameterValueAtIndex] method.
This property is assigned to varying Rebar sets only if they are numbered as a whole (i.e. NumberVaryingLengthRebarsIndividually is set to false).
The values for this property are valid if :- Input contains at least one character.
- Input contains either alphabetical or numeric characters (not both).
- For alphabetic suffix : Aaz -> Aba -> Abb.
- For numeric suffix : 129 -> 130 -> 131.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: The rebar number suffix is not valid if :
|
Autodesk.Revit.ExceptionsArgumentNullException | When setting this property: A non-optional argument was null |