Multiplies the specified number and the specified vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- value
- Type: SystemDouble
The value to multiply with the specified vector.
- right
- Type: Autodesk.Revit.DBXYZ
The vector to multiply with the value.
Return Value
The multiplied vector.Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when right is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the specified value is an infinite number. |