FlipRebarSet Method


Flips the rebar set by changing the RebarPlane with the OutOfPlaneExtent and vice versa.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023.1

Syntax

C#
public void FlipRebarSet()
Visual Basic
Public Sub FlipRebarSet
Visual C++
public:
void FlipRebarSet()

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InapplicableDataException This rebar element represents a single bar (the layout rule is Single).
Autodesk.Revit.Exceptions InvalidOperationException This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.

See Also