IsWallTypeValidForFaceWall Method


Identifies if a wall type may be applied to a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool IsWallTypeValidForFaceWall(
	Document document,
	ElementId wallType
)
Visual Basic
Public Shared Function IsWallTypeValidForFaceWall ( _
	document As Document, _
	wallType As ElementId _
) As Boolean
Visual C++
public:
static bool IsWallTypeValidForFaceWall(
	Document^ document, 
	ElementId^ wallType
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
wallType
Type: Autodesk.Revit.DBElementId
The wall type.

Return Value

True if the wall type is valid for face wall, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also