GetParameterGroupTypeId Method


Gets the ForgeTypeId identifying the built-in parameter group corresponding to BuiltInParameterGroup value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public static ForgeTypeId GetParameterGroupTypeId(
	BuiltInParameterGroup builtInParamGroup
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")> _
Public Shared Function GetParameterGroupTypeId ( _
	builtInParamGroup As BuiltInParameterGroup _
) As ForgeTypeId
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public:
static ForgeTypeId^ GetParameterGroupTypeId(
	BuiltInParameterGroup builtInParamGroup
)

Parameters

builtInParamGroup
Type: Autodesk.Revit.DBBuiltInParameterGroup
The BuiltInParameterGroup value.

Return Value

Identifier of the parameter group corresponding to the given BuiltInParameterGroup value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also