IsUpdaterEnabled Method


Checks if the updater is enabled or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static bool IsUpdaterEnabled(
	UpdaterId id
)
Visual Basic
Public Shared Function IsUpdaterEnabled ( _
	id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterEnabled(
	UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DBUpdaterId
The updater id.

Return Value

Returns true if the updater is enabled, false otherwise.

Remarks

Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not be executed regardless of its enable/disable status.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Updater with this Id is not currently registered in Revit.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also