CanExecute Method


Implement this to test whether a particular server should be executed.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
bool CanExecute(
	IExternalServer server,
	Document document,
	IExternalData data
)
Visual Basic
Function CanExecute ( _
	server As IExternalServer, _
	document As Document, _
	data As IExternalData _
) As Boolean
Visual C++
bool CanExecute(
	IExternalServer^ server, 
	Document^ document, 
	IExternalData^ data
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalServiceIExternalServer
An instance of a server that is to be tested.
document
Type: Autodesk.Revit.DBDocument
The associated document. It may be NULL if not applicable.
data
Type: Autodesk.Revit.DB.ExternalServiceIExternalData
The associated service data. It is the same data the Execute method would receive.

See Also