GetTransformed Method


Returns a transformed copy of the geometry in this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeometryElement GetTransformed(
	Transform transform
)
Visual Basic
Public Function GetTransformed ( _
	transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetTransformed(
	Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DBTransform
The transformation to apply to the geometry.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionTransform is not conformal

See Also