Constructs a ClassificationEntry object
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- key
- Type: SystemString
The key of this ClassificationEntry.
- parentKey
- Type: SystemString
The parent key of this ClassificationEntry.
- description
- Type: SystemString
The description associated with this ClassificationEntry.
- level
- Type: SystemInt32
The level of this ClassficationEntry.
- categoryId
- Type: Autodesk.Revit.DBElementId
The category id of this ClassificationEntry. The category can be invalidElementId, otherwise it must represent Revit existing category.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | key is an empty string. -or- The categoryId is not appropriate category id for classfication entry. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |