ViewSheetSet Class


Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ViewSheetSet : Element, 
	IViewSheetSet
Visual Basic
Public Class ViewSheetSet _
	Inherits Element _
	Implements IViewSheetSet
Visual C++
public ref class ViewSheetSet : public Element, 
	IViewSheetSet

Remarks

For the in-session ViewSheetSet, see the class InSessionViewSheetSet. Changes of ViewSheetSet would be effiective after [!:Autodesk::Revit::DB::ViewSheetSetting::Save]

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBViewSheetSet

See Also