CurrentRating Property


The current rating value of the analytical bus.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public double CurrentRating { get; set; }
Visual Basic
Public Property CurrentRating As Double
	Get
	Set
Visual C++
public:
property double CurrentRating {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The given value for rating is not a number -or- When setting this property: The given value for rating is not finite
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The given value for rating must be non-negative.

See Also