ElectricalAnalyticalNode Class


Represents an electrical analytical node under the Analytical Power Distribution in the System Browser.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public class ElectricalAnalyticalNode : Element
Visual Basic
Public Class ElectricalAnalyticalNode _
	Inherits Element
Visual C++
public ref class ElectricalAnalyticalNode : public Element

Remarks

This represents one of any number of types, as specified by the ElectricalAnalyticalNodeType. Some of those types will have AnalyticalDistributionNodePropertyData while others will not, and if they do have data they can be downcast to a specific subclass of data to be used.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.ElectricalElectricalAnalyticalNode

See Also