NewSpaces2 Method (Phase, Int32)


Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewSpaces2(
	Phase phase,
	int count
)
Visual Basic
Public Function NewSpaces2 ( _
	phase As Phase, _
	count As Integer _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewSpaces2(
	Phase^ phase, 
	int count
)

Parameters

phase
Type: Autodesk.Revit.DBPhase
The phase in which the spaces are to exist.
count
Type: SystemInt32

Return Value

If successful, a set of ElementIds of new unplaced spaces are be returned, otherwise a null reference (Nothing in Visual Basic).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the phase does not exist in the given document.

See Also