CanFilterByValue Method


Checks whether a field can be used with a value-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool CanFilterByValue(
	ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByValue ( _
	fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByValue(
	ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DBScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a value based filter, false otherwise.

Remarks

The value-based filter types are Equal, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Only certain types of parameters can be filtered by value.

Note that some fields (for example, Workset, Family, Type, Family and Type) only support Equal, NotEqual, but not GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also