GetDefaultNameForNoteBlock Method


Gets the default view name that will be used when creating a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static string GetDefaultNameForNoteBlock(
	Document document
)
Visual Basic
Public Shared Function GetDefaultNameForNoteBlock ( _
	document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForNoteBlock(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also