SetSimpleType Method


Sets the corresponding IFC type by its name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void SetSimpleType(
	string typeName
)
Visual Basic
Public Sub SetSimpleType ( _
	typeName As String _
)
Visual C++
public:
void SetSimpleType(
	String^ typeName
)

Parameters

typeName
Type: SystemString
The name of the type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also