UnsetActiveServer Method


Unset the active server for the particular document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void UnsetActiveServer(
	Document document
)
Visual Basic
Public Sub UnsetActiveServer ( _
	document As Document _
)
Visual C++
public:
void UnsetActiveServer(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument

Remarks

After unsetting the active server, the document will be using the application-wide active server, if one was already set.

Note it is not possible to unset a server that acts as an application-wide active server for a service. On the other hand, there should be no reason to ever do so, for each and every registered service should have (ideally) an active server set applicatiton-wide.

For a service which has cref="Autodesk::Revit::DB::ExternalService::SupportActivation" set to false calling this method will throw exception. For this kind of service only one server can be added, and it will be marked by default as an application-wide active server.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The operation is not allowed because the service is being executed. -or- For a service that doesn't support activation, the servers can't be activated/deactivated.

See Also