GetCurve Method


Returns curve that define geometry of the line boundary conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public Curve GetCurve()
Visual Basic
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Remarks

Boundary conditions should be BoundaryConditionsType::Line type. Otherwise exception is thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidObjectException Thrown when BoundaryConditions is not a BoundaryConditionsType::Line type.

See Also