SetThermalAsset Method


Sets a copy of the given ThermalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetThermalAsset(
	ThermalAsset thermalAsset
)
Visual Basic
Public Sub SetThermalAsset ( _
	thermalAsset As ThermalAsset _
)
Visual C++
public:
void SetThermalAsset(
	ThermalAsset^ thermalAsset
)

Parameters

thermalAsset
Type: Autodesk.Revit.DBThermalAsset

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also