Transform1D Constructor (Double)


Constructs the transformation by specifying the scale only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public Transform1D(
	double scale
)
Visual Basic
Public Sub New ( _
	scale As Double _
)
Visual C++
public:
Transform1D(
	double scale
)

Parameters

scale
Type: SystemDouble
The scale of the transformation.

Remarks

The translation is set to zero. 1D space is tranformed according to the following formula: t --> scale*t + translation This constructor sets translation to zero.

See Also