Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- refPlane
- Type: Autodesk.Revit.DBPlane
The geometry of the new reference plane.
- boundingBoxUV
- Type: Autodesk.Revit.DBBoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |