Creates a filter rule that determines whether double-precision values from the document equal a certain value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameter
- Type: Autodesk.Revit.DBElementId
A double-typed parameter used to get values from the document for a given element.
- value
- Type: SystemDouble
The user-supplied value against which values from the document will be compared.
- epsilon
- Type: SystemDouble
Defines the tolerance within which two values may be considered equal.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |