Places a new instance of the Structural Fabric Reinforcement Symbol into the project relative to a particular FabricSheet and View.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- viewId
- Type: Autodesk.Revit.DBElementId
The id of the view in which the symbol should appear.
- hostId
- Type: Autodesk.Revit.DBLinkElementId
The ElementId of FabricSheet (either in the document, or linked from another document).
- point
- Type: Autodesk.Revit.DBXYZ
The span symbol's head position.
- symbolId
- Type: Autodesk.Revit.DBElementId
The id of the family symbol of this symbol.
Return Value
A reference to the newly-created symbol.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | hostId should refer to a FabricSheet element. -or- viewId does not refer to a valid view type for FabricReinSpanSymbol - only floor plan, reflected ceiling plans and elevations are permitted. -or- symbolId should refer to a FamilySymbol of category OST_FabricReinSpanSymbol. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |