CanDisconnectFromUpstreamNode Method


Verifies that the area based load can disconnect from the upstream electrical analytical node. If the area based load hasn't an upstream node, it can't disconnect from the upstream node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public bool CanDisconnectFromUpstreamNode()
Visual Basic
Public Function CanDisconnectFromUpstreamNode As Boolean
Visual C++
public:
bool CanDisconnectFromUpstreamNode()

Return Value

True if the area based load can disconnect from the upstream electrical analytical node.

Remarks

If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.

See Also