AddVertex Method


Inserts a VertexStreamPositionNormalColored into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddVertex(
	VertexPositionNormalColored vertex
)
Visual Basic
Public Sub AddVertex ( _
	vertex As VertexPositionNormalColored _
)
Visual C++
public:
void AddVertex(
	VertexPositionNormalColored^ vertex
)

Parameters

vertex
Type: Autodesk.Revit.DB.DirectContext3DVertexPositionNormalColored
The vertex to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also