GetConstraintType Method


Returns the RebarConstraintType of a RebarConstraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public RebarConstraintType GetConstraintType()
Visual Basic
Public Function GetConstraintType As RebarConstraintType
Visual C++
public:
RebarConstraintType GetConstraintType()

Return Value

The RebarConstraintType of the specified RebarConstraint.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException RebarConstraint is no longer valid.

See Also