Get the ElementId value for an overriden parameter.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paramId
- Type: Autodesk.Revit.DBElementId
The id of the parameter
Return Value
The override value of the parameter.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | paramId is not the id of a parameter in the current document, or its value type is not ElementId. -or- paramId is not a Rebar Container parameter -or- paramId has no override |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |