SetAttribute Method (String, IFCAnyHandle)


Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void SetAttribute(
	string name,
	IFCAnyHandle value
)
Visual Basic
Public Sub SetAttribute ( _
	name As String, _
	value As IFCAnyHandle _
)
Visual C++
public:
void SetAttribute(
	String^ name, 
	IFCAnyHandle^ value
)

Parameters

name
Type: SystemString
The attribute name.
value
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also