AddStackedItems Method (RibbonItemData, RibbonItemData, RibbonItemData)


Adds three stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<RibbonItem> AddStackedItems(
	RibbonItemData item1,
	RibbonItemData item2,
	RibbonItemData item3
)
Visual Basic
Public Function AddStackedItems ( _
	item1 As RibbonItemData, _
	item2 As RibbonItemData, _
	item3 As RibbonItemData _
) As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ AddStackedItems(
	RibbonItemData^ item1, 
	RibbonItemData^ item2, 
	RibbonItemData^ item3
)

Parameters

item1
Type: Autodesk.Revit.UIRibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.
item2
Type: Autodesk.Revit.UIRibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.
item3
Type: Autodesk.Revit.UIRibbonItemData
Data containing information about the third item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.

Return Value

A collection containing the added items.

Remarks

Each new item may either be a PushButton, PulldownButton, SplitButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when item1, item2 or item3 is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionThrown when an item with item1.Name or item2.Name or item3.Name already exists in the panel or the data is not of the correct type.

See Also