DeleteRule Method


Deletes a performance adviser rule from the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void DeleteRule(
	PerformanceAdviserRuleId id
)
Visual Basic
Public Sub DeleteRule ( _
	id As PerformanceAdviserRuleId _
)
Visual C++
public:
void DeleteRule(
	PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DBPerformanceAdviserRuleId
An id of the rule to be deleted from the list of rules.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also