CreateNotEqualsRule Method (ElementId, Double, Double)


Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
	ElementId parameter,
	double value,
	double epsilon
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
	parameter As ElementId, _
	value As Double, _
	epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
	ElementId^ parameter, 
	double value, 
	double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DBElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: SystemDouble
The user-supplied value against which values from the document will be compared.
epsilon
Type: SystemDouble
Defines the tolerance within which two values may be considered equal.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also