IsFaceExposed Method


Checks whether the specified face is considered exposed, and therefore has an associated CoverType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public bool IsFaceExposed(
	Reference face
)
Visual Basic
Public Function IsFaceExposed ( _
	face As Reference _
) As Boolean
Visual C++
public:
bool IsFaceExposed(
	Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DBReference

Return Value

True if %face% is exposed, false otherwise.

Remarks

This method replaces the method HasCoverTypeForReference() from the 2011 Revit API.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also