ProjectReportType Property


Report type: None, simple, standard, detailed

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public HVACLoadLoadsReportType ProjectReportType { get; set; }
Visual Basic
Public Property ProjectReportType As HVACLoadLoadsReportType
	Get
	Set
Visual C++
public:
property HVACLoadLoadsReportType ProjectReportType {
	HVACLoadLoadsReportType get ();
	void set (HVACLoadLoadsReportType value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The project report type does not fall within an appropriate range.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also