SetDefaultLengthUnit Method


Set the default length unit used for importing unitless files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022.1

Syntax

C#
public void SetDefaultLengthUnit(
	ForgeTypeId specTypeId
)
Visual Basic
Public Sub SetDefaultLengthUnit ( _
	specTypeId As ForgeTypeId _
)
Visual C++
public:
void SetDefaultLengthUnit(
	ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DBForgeTypeId
The default length unit.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given specTypeId is not a supported unit of length.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also