GetSubelement Method (ElementId, Int32)


Gets the subelement referenced by a parent id and subelement id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019

Syntax

C#
public Subelement GetSubelement(
	ElementId id,
	int subId
)
Visual Basic
Public Function GetSubelement ( _
	id As ElementId, _
	subId As Integer _
) As Subelement
Visual C++
public:
Subelement^ GetSubelement(
	ElementId^ id, 
	int subId
)

Parameters

id
Type: Autodesk.Revit.DBElementId
Id of the element.
subId
Type: SystemInt32
Id of the sub element.

Return Value

The subelement referenced by the input argument.

Remarks

a null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also