FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType)


Constructs a new instance of a filter to match families that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
	StructuralMaterialType structuralMaterialType
)
Visual Basic
Public Sub New ( _
	structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
	StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.StructureStructuralMaterialType
The structural material type to match.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also