FamilyInstanceFilter Constructor


Constructs a new instance of a filter to match family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public FamilyInstanceFilter(
	Document document,
	ElementId familySymbolId
)
Visual Basic
Public Sub New ( _
	document As Document, _
	familySymbolId As ElementId _
)
Visual C++
public:
FamilyInstanceFilter(
	Document^ document, 
	ElementId^ familySymbolId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document. This requirement is unique to this filter and is needed to ensure the input family symbol id is valid for the provided document. This ensures the most stability and greatest performance for this filter.
familySymbolId
Type: Autodesk.Revit.DBElementId
The family symbol id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The familySymbolId does not represent a valid FamilySymbol record in the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also