ElementClassFilter Constructor (Type)


Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public ElementClassFilter(
	Type type
)
Visual Basic
Public Sub New ( _
	type As Type _
)
Visual C++
public:
ElementClassFilter(
	Type^ type
)

Parameters

type
Type: SystemType
The type to match.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also