This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- newToLocation
- Type: Autodesk.Revit.DBXYZ
The desired "to" location
Return Value
The valid "to" location.Remarks
If the point is already an acceptable "to" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |