GetCycleCounter Method


Gets the cycle counter that is stored in the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int GetCycleCounter()
Visual Basic
Public Function GetCycleCounter As Integer
Visual C++
public:
int GetCycleCounter()

Return Value

Returns the cycle counter.

Remarks

The cycle counter value is changed when the free form Rebar element is selected and the user press Space key -or- by through [!:Autodesk::Revit::DB::Structure::RebarRebarFreeFormAccessor::CycleCounter] property. -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0).

See Also