Evaluate Method (Int32, Int32)


Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
public bool Evaluate(
	int lhs,
	int rhs
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")> _
Public Function Evaluate ( _
	lhs As Integer, _
	rhs As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
public:
bool Evaluate(
	int lhs, 
	int rhs
)

Parameters

lhs
Type: System Int32
A value from an element in the document.
rhs
Type: System Int32
The user-supplied value against which values from the document are tested.

Return Value

True if lhs , rhs satisfy the condition implemented by this evaluator.

See Also