Indicates if leading zeros should be suppressed in feet and fractional inches.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
True if leading zeros should be suppressed, false otherwise. The default is false.Remarks
This property is applicable to display units related to feet and fractional inches:
- DUT_FEET_FRACTIONAL_INCHES
- DUT_RISE_OVER_FOOT
- DUT_RISE_OVER_10_FEET
When SuppressLeadingZeros is true:
- If the foot component of the value is zero (the value is less than one foot), it will not be displayed. For example, 0' - 2 3/4" will be displayed as 2 3/4".
- If both the foot and integer inch components of the value are zero (the value is less than one inch), neither will be displayed. For example, 0' - 0 3/4" will be displayed as 3/4".
- However, an integer inch component of zero will be displayed if the foot component is non-zero. For example 1' - 0 3/4" will be displayed as 1' - 0 3/4".
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: SuppressLeadingZeros was set to true but leading zeros cannot be suppressed for the display unit in this FormatOptions. |