RemoveMacro Method


Removes a macro from the module.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void RemoveMacro(
	Macro macro
)
Visual Basic
Public Sub RemoveMacro ( _
	macro As Macro _
)
Visual C++
public:
void RemoveMacro(
	Macro^ macro
)

Parameters

macro
Type: Autodesk.Revit.DB.MacrosMacro
The macro will be removed from this module.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Cannot remove the Macro due to no permission.

See Also