GetSectionData Method


Gets section data that will be written to

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableSectionData GetSectionData(
	SectionType sectionType
)
Visual Basic
Public Function GetSectionData ( _
	sectionType As SectionType _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
	SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DBSectionType
The section type

Return Value

The TableSectionData

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also