ValidateViewType Method


Validates the incoming view type. As of today, the only allowed view type is Plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static bool ValidateViewType(
	DirectShapeTargetViewType targetViewType
)
Visual Basic
Public Shared Function ValidateViewType ( _
	targetViewType As DirectShapeTargetViewType _
) As Boolean
Visual C++
public:
static bool ValidateViewType(
	DirectShapeTargetViewType targetViewType
)

Parameters

targetViewType
Type: Autodesk.Revit.DBDirectShapeTargetViewType

Return Value

True if %targetViewType% is DirectShapeTargetViewType::Plan

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also