Sets the presentation mode for this rebar set when displayed in the given view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- dBView
- Type: Autodesk.Revit.DBView
The view.
- presentationMode
- Type: Autodesk.Revit.DB.StructureRebarPresentationMode
The presentation mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This rebar cannot have a presentation mode applied for dBView, as the view is not valid for rebar presentation, or the orientation of the view matches the normal direction of the rebar. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |