GetDefaultResolutionType Method


Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The Default resolution type for the failure.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException FailureDefinition does not have any resolutions.

See Also